Skip to content

Override postcss-selector-parser to fix security alert - #691

Merged
mniewrzal merged 1 commit into
mainfrom
fix/postcss-selector-parser-override
Oct 30, 2026
Merged

mniewrzal merged 1 commit into
mainfrom
fix/postcss-selector-parser-override

Conversation

@mniewrzal

Copy link
Copy Markdown
Contributor

@tailwindcss/typography (up to 0.5.20) pins postcss-selector-parser to exactly 6.0.10, so Dependabot cannot update it to the patched 6.1.5. Force it with an npm override. Remove the override once typography drops the exact pin.

@tailwindcss/typography (up to 0.5.20) pins postcss-selector-parser to
exactly 6.0.10, so Dependabot cannot update it to the patched 6.1.5.
Force it with an npm override. Remove the override once typography
drops the exact pin.

Co-Authored-By: Claude Opus 5.5 <noreply@anthropic.com>
Claude-Session: https://claude.ai/code/session_019njSSSsotmfQs11tZcaQkY
@github-actions

Copy link
Copy Markdown

Firebase preview

Preview URL: https://storj-dev--pr-691-ia02vrpz.web.app

Expires: Fri, 06 Nov 2026 08:39:34 GMT

@mniewrzal
mniewrzal merged commit 86692c1 into main Oct 30, 2026
2 checks passed
@mniewrzal
mniewrzal deleted the fix/postcss-selector-parser-override branch October 30, 2026 08:41

This branch was successfully deployed

1 active deployment
Preview — 8e8e1059 Deployed Oct 30, 2026 by github-actions[bot]
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant