Skip to content

Livekit Deployment on OpenShift #139

Description

@vikki625

Hi Team,

While deploying livekit-server on OpenShift using a Service of type LoadBalancer, I encountered a 503 Service Unavailable error. After investigation, I found that the root cause is due to mixing TCP and UDP ports in a single Service definition, which is not supported in Kubernetes/OpenShift.

Problem:
The current service definition attempts to expose:

TCP ports: 7880, 7881
UDP ports: 7882, 50000, 60000

This causes OpenShift to fail in creating the corresponding Endpoints object, resulting in no backend being available for routing, and hence the 503 error.

Can you please share your insights on how to address this issue.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions