Skip to content

fix(deps): align Expo SDK 58 patch versions - #67

Open
TheStreamCode wants to merge 1 commit into
mainfrom
fix/expo-sdk-58-patch-drift
Open

TheStreamCode wants to merge 1 commit into
mainfrom
fix/expo-sdk-58-patch-drift

Conversation

@TheStreamCode

Copy link
Copy Markdown
Owner

Summary

Fix the expo-doctor failure that blocks every pull request.

CI reported one failed check: packages that do not match the versions required by Expo SDK 58. The drift is newer than the last green run on main.

  • @expo/metro-runtime ~58.0.16 to ~58.0.17
  • expo ~58.0.22 to ~58.0.23
  • expo-asset ~58.0.19 to ~58.0.20
  • expo-constants ~58.0.14 to ~58.0.15
  • expo-notifications ~58.1.7 to ~58.1.8
  • expo-sharing ~58.0.21 to ~58.0.22
  • expo-updates ~58.0.20 to ~58.0.21
  • react-native-safe-area-context ~5.10.1 to ~5.11.1
  • jest-expo ~58.0.13 to ~58.0.14
  • bun.lock regenerated

Verification

  • bun install from a clean node_modules
  • bunx expo-doctor: 20/20 checks passed
  • bun run verify: formatting, strict TypeScript, ESLint, 36 Jest suites / 254 tests, Expo Doctor 20/20

No application code changed; only dependency versions.

expo-doctor failed on CI because eight packages lagged the patch versions SDK 58 expects. Update them to the SDK-aligned ranges and regenerate bun.lock.

Co-authored-by: Copilot App <223556219+Copilot@users.noreply.github.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant